7.5High
CVE-2026-69080Apache Kylin: Broken Access Control in QuerySQLBlacklistController
Description
Exposure of SQL Black List to an Unauthorized Actor vulnerability in Apache Kylin. This issue affects Apache Kylin: from 4 through 5.0.4. Users are recommended to upgrade to version 5.0.5, which fixes the issue.
Weakness (CWE):
CWE-200
Data: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Published as the sources state it, in English.
Affected products and versions
| Vendor | Product | Versions | |
|---|---|---|---|
| Apache Software Foundation | Apache Kylin | 4..0.0 – ≤ 5.0.4 |