8.2High KEV

CVE-2025-58360GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature

geoserver geoserver Published: (11 months ago)

Known exploited — OSGeo GeoServer Improper Restriction of XML External Entity Reference Vulnerability

CISA confirmed this vulnerability is used in real attacks on 11.12.2025. Remediation deadline for US federal agencies: 01.01.2026.

Required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable. This vulnerability affects an open-source component, third-party library, or a protocol used by different products. For more information, please see: https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525 ; https://osgeo-org.atlassian.net/browse/GEOS-11922 ; https://nvd.nist.gov/vuln/detail/CVE-2025-58360

Description

GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.

Weakness (CWE): CWE-611

Data: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Published as the sources state it, in English.

Affected products and versions

VendorProductVersions
geoserver geoserver >= 2.26.0, < 2.26.2, < 2.25.6

References and patches

CPE matches (NVD) (2)

  • cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:* < 2.25.6
  • cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:* ≥ 2.26.0 < 2.26.2