8.2Hoch KEV

CVE-2025-58360GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature

geoserver geoserver Veröffentlicht: (vor 11 Monaten)

Bekannt ausgenutzt — OSGeo GeoServer Improper Restriction of XML External Entity Reference Vulnerability

CISA hat am 11.12.2025 bestätigt, dass diese Schwachstelle in echten Angriffen genutzt wird. Frist für US-Bundesbehörden: 01.01.2026.

Erforderliche Maßnahme: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable. This vulnerability affects an open-source component, third-party library, or a protocol used by different products. For more information, please see: https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525 ; https://osgeo-org.atlassian.net/browse/GEOS-11922 ; https://nvd.nist.gov/vuln/detail/CVE-2025-58360

Beschreibung

GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.

Schwachstellentyp (CWE): CWE-611

Daten: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Wiedergegeben wie in der Quelle, auf Englisch.

Betroffene Produkte und Versionen

HerstellerProduktVersionen
geoserver geoserver >= 2.26.0, < 2.26.2, < 2.25.6

Referenzen und Patches

CPE-Treffer (NVD) (2)

  • cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:* < 2.25.6
  • cpe:2.3:a:geoserver:geoserver:*:*:*:*:*:*:*:* ≥ 2.26.0 < 2.26.2