Açıklama
Envoy is an open source edge and service proxy designed for cloud-native applications. From 1.23.0 until 1.35.11, 1.36.7, 1.37.3, and 1.38.1, a vulnerability has been identified in Envoy's zstd decompressor implementation (ZstdDecompressorImpl). When zstd decompression is enabled, processing a specially crafted, highly compressed zstd payload can lead to massive memory allocation. An attacker can exploit this to cause severe memory exhaustion, potentially resulting in an Out-Of-Memory (OOM) kill and Denial of Service (DoS) for the Envoy proxy. This vulnerability is fixed in 1.35.11, 1.36.7, 1.37.3, and 1.38.1.
Veri: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Bilgiler kaynaktaki haliyle, İngilizce yayımlanır.
Etkilenen ürünler ve sürümler
| Üretici | Ürün | Sürümler | |
| envoyproxy |
envoy |
>= 1.38.0, < 1.38.1, >= 1.37.0, < 1.37.3, >= 1.36.0, < 1.36.7, >= 1.23.0, < 1.35.11 |
|
CPE eşleşmeleri (NVD) (4)
cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* ≥ 1.23.0 < 1.35.13cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* ≥ 1.36.0 < 1.36.9cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* ≥ 1.37.0 < 1.37.5cpe:2.3:a:envoyproxy:envoy:*:*:*:*:*:*:*:* ≥ 1.38.0 < 1.38.3