8.2Yüksek

CVE-2024-32004Git vulnerable to Remote Code Execution while cloning special-crafted local repositories

git git Yayım: (2 yıl önce)

Açıklama

Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, an attacker can prepare a local repository in such a way that, when cloned, will execute arbitrary code during the operation. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid cloning repositories from untrusted sources.

Zayıflık türü (CWE): CWE-114

Veri: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Bilgiler kaynaktaki haliyle, İngilizce yayımlanır.

Etkilenen ürünler ve sürümler

ÜreticiÜrünSürümler
git git = 2.45.0, = 2.44.0, >= 2.43.0, < 2.43.4, >= 2.42.0, < 2.42.2, = 2.41.0, >= 2.40.0, < 2.40.2, < 2.39.4

Kaynaklar ve yamalar