10.0Kritik KEV Fidye yazılımında kullanılıyor

CVE-2023-46604Apache ActiveMQ, Apache ActiveMQ Legacy OpenWire Module: Unbounded deserialization causes ActiveMQ to be vulnerable to a remote code execution (RCE) attack

Apache Software Foundation Apache ActiveMQ; Apache Software Foundation Apache ActiveMQ Legacy OpenWire Module Yayım: (3 yıl önce)

Aktif olarak istismar ediliyor — Apache ActiveMQ Deserialization of Untrusted Data Vulnerability

CISA bu açığın gerçek saldırılarda kullanıldığını 02.11.2023 tarihinde doğruladı. ABD federal kurumları için düzeltme son tarihi: 23.11.2023.

Gerekli işlem: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable. https://activemq.apache.org/security-advisories.data/CVE-2023-46604-announcement.txt; https://nvd.nist.gov/vuln/detail/CVE-2023-46604

Açıklama

The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause either the client or the broker (respectively) to instantiate any class on the classpath. Users are recommended to upgrade both brokers and clients to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3 which fixes this issue.

Zayıflık türü (CWE): CWE-502

Veri: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Bilgiler kaynaktaki haliyle, İngilizce yayımlanır.

Etkilenen ürünler ve sürümler

ÜreticiÜrünSürümler
apache activemq < 5.15.16
apache activemq legacy openwire module < 5.15.16
Apache Software Foundation Apache ActiveMQ 5.18.0 – < 5.18.3, 5.17.0 – < 5.17.6, 5.16.0 – < 5.16.7, < 5.15.16
Apache Software Foundation Apache ActiveMQ Legacy OpenWire Module 5.18.0 – < 5.18.3, 5.17.0 – < 5.17.6, 5.16.0 – < 5.16.7, 5.8.0 – < 5.15.16
debian debian linux 10.0
netapp e-series santricity unified manager —
netapp e-series santricity web services proxy —
netapp santricity storage plugin —

Kaynaklar ve yamalar

CPE eşleşmeleri (NVD) (13)

  • cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* < 5.15.16
  • cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* ≥ 5.16.0 < 5.16.7
  • cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* ≥ 5.17.0 < 5.17.6
  • cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* ≥ 5.18.0 < 5.18.3
  • cpe:2.3:a:apache:activemq_legacy_openwire_module:*:*:*:*:*:*:*:* < 5.15.16
  • cpe:2.3:a:apache:activemq_legacy_openwire_module:*:*:*:*:*:*:*:* ≥ 5.16.0 < 5.16.7
  • cpe:2.3:a:apache:activemq_legacy_openwire_module:*:*:*:*:*:*:*:* ≥ 5.17.0 < 5.17.6
  • cpe:2.3:a:apache:activemq_legacy_openwire_module:*:*:*:*:*:*:*:* ≥ 5.18.0 < 5.18.3
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*
  • cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*
  • cpe:2.3:a:netapp:e-series_santricity_unified_manager:-:*:*:*:*:*:*:*
  • cpe:2.3:a:netapp:e-series_santricity_web_services_proxy:-:*:*:*:*:*:*:*
  • cpe:2.3:a:netapp:santricity_storage_plugin:-:*:*:*:*:vcenter:*:*