CVE-2019-11580Atlassian Crowd and Crowd Data Center Remote Code Execution Vulnerability
Aktif olarak istismar ediliyor — Atlassian Crowd and Crowd Data Center Remote Code Execution Vulnerability
CISA bu açığın gerçek saldırılarda kullanıldığını 03.11.2021 tarihinde doğruladı. ABD federal kurumları için düzeltme son tarihi: 03.05.2022.
Gerekli işlem: Apply updates per vendor instructions. https://nvd.nist.gov/vuln/detail/CVE-2019-11580
Açıklama
Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.
Veri: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Bilgiler kaynaktaki haliyle, İngilizce yayımlanır.
Etkilenen ürünler ve sürümler
Kaynaklar ve yamalar
- https://jira.atlassian.com/browse/CWD-5388 Issue TrackingMitigationVendor Advisory
- 108637 vdb-entryBroken Link
- http://packetstormsecurity.com/files/163810/Atlassian-Crowd-pdkinstall-Remote-Code-Execution.html ExploitThird Party AdvisoryVDB Entry
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2019-11580 US Government Resource
CPE eşleşmeleri (NVD) (5)
cpe:2.3:a:atlassian:crowd:*:*:*:*:*:*:*:*≥ 2.1.0 < 3.0.5cpe:2.3:a:atlassian:crowd:*:*:*:*:*:*:*:*≥ 3.1.0 < 3.1.6cpe:2.3:a:atlassian:crowd:*:*:*:*:*:*:*:*≥ 3.2.0 < 3.2.8cpe:2.3:a:atlassian:crowd:*:*:*:*:*:*:*:*≥ 3.3.0 < 3.3.5cpe:2.3:a:atlassian:crowd:*:*:*:*:*:*:*:*≥ 3.4.0 < 3.4.4