Vulnerabilidades de Exim

Registros CVE publicados para Exim Exim, los más recientes primero. Siga el producto para recibir un correo con cada nueva.

Feed RSS
CVE totales26
Últimos 30 días0
Críticas6
Explotadas5
26 resultados
4.0Media
CVE-2026-94057
Exim Exim

Exim before 4.100.1 allows SMTP smuggling in which the received message does not match any sent message, and instead depends on crafted data sent after a rejection during DATA processing.

7.5Alta
CVE-2026-94056
Exim Exim

Exim before 4.100.1, when Proxy-Protocol is used with an attacker-controlled proxy, allows attackers to read certain uninitialized data from stack memory.

3.7Baja
CVE-2026-94055
Exim Exim

Exim before 4.100.1, when certain non-default TLS settings are used with GnuTLS, has a use-after-free.

7.0Alta
CVE-2026-94054
Exim Exim

Exim before 4.100.1, when Proxy-Protocol is used with an attacker-controlled proxy, has an out-of-bounds write.

7.4Alta
CVE-2026-66141
Exim Exim

Exim before 4.99.5 allows .forward privilege escalation because force_command for a pipe transport is mishandled.

8.4Alta
CVE-2026-66140
Exim Exim

Exim before 4.99.5 allows directory traversal to access files outside of the spool area, and consequently gain privileges, because arguments related to queue-name are mishandled.

5.3Media
CVE-2026-48840
Exim Exim

Exim 4.88 before 4.99.4, in some proxy configurations, mishandles certain short payloads, leading to disclosure of uninitialized stack memory values to a client.

9.8Crítica
CVE-2026-45185
Exim Exim

Exim before 4.99.3, in certain GnuTLS configurations, has a remotely reachable use-after-free in the BDAT body parsing path. It is triggered when a client sends a TLS close_notify mid-body during a CHUNKING transfer, followed by a final cleartext byte on the …

1.3%EPSS
4.8Media
CVE-2026-40687
Exim Exim

In Exim before 4.99.2, when the SPA authentication driver is used with an adversarial SPA resource, there can be an out-of-bounds write that crashes the connection instance, or erroneous data processing that divulges data from uninitialized heap memory.

3.7Baja
CVE-2026-40686
Exim Exim

In Exim before 4.99.2, when utf8 operators are enabled, there is an out-of-bounds read if large UTF-8 trailing characters are present (malformed UTF-8 header data). Information might be divulged within an error message produced during handling of an unrelated…

6.5Media
CVE-2026-40685
Exim Exim

In Exim before 4.99.2, when JSON lookup is enabled, an out-of-bounds heap write can occur when a JSON operator encounters malformed JSON in an untrusted header, because of an incorrect implementation of \ skipping.

5.9Media
CVE-2026-40684
Exim Exim

In Exim before 4.99.2, on systems using musl libc (not glibc), an attacker can crash the connection instance when malformed DNS data is present in PTR records. This is caused by a dn_expand oddity in octal printing.

7.0Alta
CVE-2025-67896
Exim Exim

Exim before 4.99.1, with certain non-default rate-limit configurations, allows a remote heap-based buffer overflow because database records are cast directly to internal structures without validation.

8.1Alta
CVE-2025-30232
Exim Exim

A use-after-free in Exim 4.96 through 4.98.1 could allow users (with command-line access) to escalate privileges.

7.5Alta
CVE-2025-26794
Exim Exim

Exim 4.98 before 4.98.1, when SQLite hints and ETRN serialization are used, allows remote SQL injection. (Resolving SQL injection requires an update to 4.99.1 in certain non-default rate-limit configurations.)

78%EPSS
5.4Media
CVE-2024-39929
exim exim

Exim through 4.97.1 misparses a multiline RFC 2231 header filename, and thus remote attackers can bypass a $mime_filename extension-blocking protection mechanism, and potentially deliver executable attachments to the mailboxes of end users.

41%EPSS
9.8Crítica
CVE-2023-42115

Exim AUTH Out-Of-Bounds Write Remote Code Execution Vulnerability

Exim Exim; exim exim

Exim AUTH Out-Of-Bounds Write Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Exim. Authentication is not required to exploit this vulnerability. The specific flaw exists…

12%EPSS
9.8Crítica
CVE-2019-16928 KEV

Exim Out-of-bounds Write Vulnerability

exim exim; canonical ubuntu linux; debian debian linux; fedoraproject fedora

Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than CVE-2019-15846. There is a heap-based buffer overflow in string_vformat in string.c involving a long EHLO command.

42%EPSS
9.8Crítica
CVE-2018-6789 KEV Usada en ransomware

Exim Buffer Overflow Vulnerability

exim exim; debian debian linux; canonical ubuntu linux

An issue was discovered in the base64d function in the SMTP listener in Exim before 4.90.1. By sending a handcrafted message, a buffer overflow may happen. This can be used to execute code remotely.

82%EPSS
7.8Alta
CVE-2010-4345 KEV

Exim Privilege Escalation Vulnerability

exim exim; opensuse opensuse; debian debian linux; canonical ubuntu linux

Exim 4.72 and earlier allows local users to gain privileges by leveraging the ability of the exim user account to specify an alternate configuration file with a directive that contains arbitrary commands, as demonstrated by the spool_directory directive.

18%EPSS

La lista incluye todos los registros desde inicios de 2025 y otros más antiguos de este producto.