7.4Alta

CVE-2026-116163Parse Server 9.0.0 before 9.10.5-alpha.2 Authentication Bypass via AuthAdapter Subclasses

parse-community parse-server Publicada: (hace 8 días)

Descripción

Parse Server before 8.6.102 and 9.0.0 before 9.10.5-alpha.2 contains an authentication bypass because the validateSetUp, validateLogin, and validateUpdate methods of custom adapters subclassing AuthAdapter are never called, and an inherited default that accepts any authData is used instead. Attackers can supply arbitrary authData to sign up, link identities, log in as existing users, or skip custom additional authentication factors.

Debilidad (CWE): CWE-287

Datos: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Se publican tal como los indican las fuentes, en inglés.

Productos y versiones afectados

FabricanteProductoVersiones
parse-community parse-server 9.0.0 – < 9.10.5-alpha.2, fixed 9.10.5-alpha.2
parseplatform parse-server 9.0.0 – < 9.10.5-alpha.2

Referencias y parches