WordPress (core) vulnerabilities

CVE records published for WordPress WordPress (core), newest first. Follow to get an email when a new one appears.

RSS feed
Total CVEs32
Last 30 days2
Critical2
Exploited4
32 results
8.1High
CVE-2026-87902 KEV

WordPress Core Remote File Inclusion Vulnerability

WordPress WordPress

An unauthenticated attacker can make `get_page_template()` page-template resolution include a chosen readable local `.php` file outside the active theme directories. If relevant pre-conditions for both the server and the active theme are met, this can lead to RCE.

96%EPSS
8.8High
CVE-2026-65640
WordPress WordPress

WordPress is vulnerable to a remote code execution vulnerability via malicious Postscript file upload by an Author level user or higher. Prerequisites: * Imagick and Ghostscript in use on the server * A malicious user with the `upload_files` capability This…

1.9%EPSS
8.9High
CVE-2026-64638
WordPress WordPress

WordPress is vulnerable to a pre-auth reflected XSS vulnerability on the login screen. Via a specially crafted malicious third-party website hosted by an attacker, it is possible for this to be escalated to an RCE vulnerability with conditions outside of t…

3.7Low
CVE-2025-54352
WordPress WordPress

WordPress 3.5 through 6.8.2 allows remote attackers to guess titles of private and draft posts via pingback.ping XML-RPC requests. NOTE: the Supplier is not changing this behavior.

7.2High
CVE-2024-4439
WordPress Foundation WordPress; wordpress wordpress

WordPress Core is vulnerable to Stored Cross-Site Scripting via user display names in the Avatar block in various versions up to 6.5.2 due to insufficient output escaping on the display name. This makes it possible for authenticated attackers, with contributo…

71%EPSS
4.3Medium
CVE-2023-39999

WordPress < 6.3.2 is vulnerable to Broken Access Control

WordPress.org WordPress

Exposure of Sensitive Information to an Unauthorized Actor in WordPress from 6.3 through 6.3.1, from 6.2 through 6.2.2, from 6.1 through 6.13, from 6.0 through 6.0.5, from 5.9 through 5.9.7, from 5.8 through 5.8.7, from 5.7 through 5.7.9, from 5.6 through 5.6…

1.2%EPSS
5.4Medium
CVE-2023-2745

WordPress Core < 6.2.1 - Directory Traversal

WordPress Foundation WordPress

WordPress Core is vulnerable to Directory Traversal in versions up to, and including, 6.2, via the ‘wp_lang’ parameter. This allows unauthenticated attackers to access and load arbitrary translation files. In cases where an attacker is able to upload a crafte…

79%EPSS
5.9Medium
CVE-2022-3590

WP <= 6.1.1 - Unauthenticated Blind SSRF via DNS Rebinding

WordPress WordPress

WordPress is affected by an unauthenticated blind SSRF in the pingback feature. Because of a TOCTOU race condition between the validation checks and the HTTP request, attackers can reach internal hosts that are explicitly forbidden.

3.4%EPSS
5.3Medium
CVE-2022-43504
WordPress.org WordPress

Improper authentication vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to obtain the email address of the user who posted a blog using the WordPress Post by Email Feature. The developer also provides new patched re…

1.5%EPSS
6.1Medium
CVE-2022-43500
WordPress.org WordPress

Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.

6.1Medium
CVE-2022-43497
WordPress.org WordPress

Cross-site scripting vulnerability in WordPress versions prior to 6.0.3 allows a remote unauthenticated attacker to inject an arbitrary script. The developer also provides new patched releases for all versions since 3.7.

1.3%EPSS
8.7High
CVE-2020-11026

Specially crafted filenames in WordPress leading to XSS

WordPress WordPress

In affected versions of WordPress, files with a specially crafted name when uploaded to the Media section can lead to script execution upon accessing the file. This requires an authenticated user with privileges to upload files. This has been patched in versi…

2.1%EPSS
5.8Medium
CVE-2020-11028

Unauthenticated disclosure of certain private posts in WordPress

WordPress WordPress

In affected versions of WordPress, some private posts, which were previously public, can result in unauthenticated disclosure under a specific set of conditions. This has been patched in version 5.4.1, along with all the previously affected versions via a min…

2.3%EPSS

The list holds every record since the start of 2025 and older records for this product.