8.8High
CVE-2026-9155OS Command Injection in Rapid7 InsightConnect Sed Plugin via expression parameter.
Description
OS Command Injection vulnerability in Rapid7 InsightConnect Sed Plugin on Linux allows authenticated attackers to execute arbitrary OS commands via the expression parameter due to insufficient input validation.
Weakness (CWE):
CWE-78
Data: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Published as the sources state it, in English.
Affected products and versions
| Vendor | Product | Versions | |
|---|---|---|---|
| gnu | sed | 4.2.2 | |
| Rapid7 | InsightConnect Sed Plugin | < 2.0.5, fixed 2.0.5 |
References and patches
- https://extensions.rapid7.com/extension/sed vendor-advisoryVendor Advisory
CPE matches (NVD) (1)
cpe:2.3:a:gnu:sed:4.2.2:*:*:*:*:*:*:*