7.3High

CVE-2026-55957Apache Tomcat: Authentication bypass with JNDIRealm and GSSAPI authenticated bind

Apache Software Foundation Apache Tomcat Published: (4 months ago)

Description

Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.

Weakness (CWE): CWE-304

Data: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Published as the sources state it, in English.

Affected products and versions

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – ≤ 11.0.4, 10.1.0-M1 – ≤ 10.1.36, 9.0.0.M1 – ≤ 9.0.100, 8.5.0 – ≤ 8.5.100, 7.0.0 – ≤ 7.0.109
apache tomcat < 9.0.101

References and patches

CPE matches (NVD) (3)

  • cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:* < 9.0.101
  • cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:* ≥ 10.1.0 < 10.1.37
  • cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:* ≥ 11.0.0 < 11.0.5