7.3High

CVE-2026-44185Apache HTTP Server: Stack Buffer Over-Read in mod_ssl OCSP `send_request`

Apache Software Foundation Apache HTTP Server; Red Hat JBoss Core Services for RHEL 8; Red Hat Red Hat Enterprise Linux 10; Red Hat Red Hat Enterprise Linux 10… Published: (4 months ago)

Description

Buffer Over-read vulnerability in Apache HTTP Server via outbound OCSP requests to an attacker controlled OCSP server This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

Weakness (CWE): CWE-126CWE-125

Data: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Published as the sources state it, in English.

Affected products and versions

References and patches

CPE matches (NVD) (1)

  • cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:* ≥ 2.4.0 < 2.4.68