9.3Critical KEV

CVE-2024-56145RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms

craftcms cms Published: (1 year ago)

Known exploited — Craft CMS Code Injection Vulnerability

CISA confirmed this vulnerability is used in real attacks on 02.06.2025. Remediation deadline for US federal agencies: 23.06.2025.

Required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable. https://github.com/craftcms/cms/security/advisories/GHSA-2p6p-9rc9-62j9 ; https://nvd.nist.gov/vuln/detail/CVE-2024-56145

Description

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.

Weakness (CWE): CWE-94

Data: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Published as the sources state it, in English.

Affected products and versions

VendorProductVersions
craftcms cms >= 4.0.0-RC1, < 4.13.2, >= 5.0.0-RC1, < 5.5.2, >= 3.0.0, < 3.9.14
craftcms craft cms 3.0.0 – < 3.9.14

References and patches

CPE matches (NVD) (3)

  • cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* ≥ 3.0.0 < 3.9.14
  • cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* ≥ 4.0.0 < 4.13.2
  • cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* ≥ 5.0.0 < 5.5.2