9.8Critical KEV

CVE-2023-33246Apache RocketMQ: Possible remote code execution vulnerability when using the update configuration function

Apache Software Foundation Apache RocketMQ Published: (3 years ago)

Known exploited — Apache RocketMQ Command Execution Vulnerability

CISA confirmed this vulnerability is used in real attacks on 06.09.2023. Remediation deadline for US federal agencies: 27.09.2023.

Required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable. https://lists.apache.org/thread/1s8j2c8kogthtpv3060yddk03zq0pxyp; https://nvd.nist.gov/vuln/detail/CVE-2023-33246

Description

For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution.  Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content.  To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .

Weakness (CWE): CWE-94

Data: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Published as the sources state it, in English.

Affected products and versions

VendorProductVersions
Apache Software Foundation Apache RocketMQ ≤ 5.1.0
apache rocketmq < 4.9.6

References and patches

CPE matches (NVD) (2)

  • cpe:2.3:a:apache:rocketmq:*:*:*:*:*:*:*:* < 4.9.6
  • cpe:2.3:a:apache:rocketmq:*:*:*:*:*:*:*:* ≥ 5.0.0 < 5.1.1