CVE-2026-73634Apache Struts: Unbounded read of a Content Security Policy violation report
Beschreibung
Uncontrolled resource consumption vulnerability in Apache Struts. An application that exposes an endpoint collecting Content Security Policy violation reports reads the submitted report into memory without bounding how much it will accept, so a single request can exhaust the heap and deny service to other users. Such endpoints are ordinarily reachable without authentication. The core distribution maps no such endpoint by default; applications that do not collect violation reports are not affected. This issue affects Apache Struts: from 6.0.0 through 6.10.0, from 7.0.0 through 7.2.1. Users are recommended to upgrade to version 6.11.0 or 7.3.0, which fixes the issue.
Daten: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Wiedergegeben wie in der Quelle, auf Englisch.
Betroffene Produkte und Versionen
| Hersteller | Produkt | Versionen | |
|---|---|---|---|
| Apache Software Foundation | Apache Struts | 6.0.0 – ≤ 6.10.0, 7.0.0 – ≤ 7.2.1 | |
| apache | struts | 6.0.0 – < 6.11.0 |
Referenzen und Patches
- https://cwiki.apache.org/confluence/display/WW/S2-073 vendor-advisoryVendor AdvisoryMitigation
CPE-Treffer (NVD) (2)
cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:*≥ 6.0.0 < 6.11.0cpe:2.3:a:apache:struts:*:*:*:*:*:*:*:*≥ 7.0.0 < 7.3.0