9.8Kritisch

CVE-2026-62390Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API

Apache Software Foundation Apache Kylin Veröffentlicht: (vor 3 Monaten)

Beschreibung

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Kylin. A backend API refreshing table catalog may cause the injection to the generated SQL. This issue affects Apache Kylin: from 4 through 5.0.3. Users are recommended to upgrade to version 5.0.4, which fixes the issue.

Schwachstellentyp (CWE): CWE-89

Daten: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Wiedergegeben wie in der Quelle, auf Englisch.

Betroffene Produkte und Versionen

HerstellerProduktVersionen
Apache Software Foundation Apache Kylin 4 – ≤ 5.0.3
apache kylin 4.0.0 – < 5.0.4

Referenzen und Patches

CPE-Treffer (NVD) (1)

  • cpe:2.3:a:apache:kylin:*:*:*:*:*:*:*:* ≥ 4.0.0 < 5.0.4