7.3Hoch
CVE-2026-43870Apache Thrift: Node.js web_server.js multi-vulnerability
Beschreibung
Origin Validation Error, Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Improper Neutralization of CRLF Sequences in HTTP Headers ('HTTP Request/Response Splitting'), Uncontrolled Resource Consumption vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.
Daten: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Wiedergegeben wie in der Quelle, auf Englisch.
Betroffene Produkte und Versionen
| Hersteller | Produkt | Versionen | |
|---|---|---|---|
| Apache Software Foundation | Apache Thrift | < 0.23.0 | |
| apache | thrift | < 0.23.0 |
Referenzen und Patches
- https://lists.apache.org/thread/pgtfq44ltc9t63kxcbqmwqzt45pnhqdy vendor-advisoryVendor Advisory
- http://www.openwall.com/lists/oss-security/2026/05/05/4 Mailing ListThird Party Advisory
CPE-Treffer (NVD) (1)
cpe:2.3:a:apache:thrift:*:*:*:*:*:*:*:*< 0.23.0