8.7Hoch KEV

CVE-2026-42271LiteLLM: Authenticated command execution via MCP stdio test endpoints

BerriAI litellm; Red Hat Red Hat OpenShift AI 2.25; Red Hat Red Hat OpenShift AI 3.3; Red Hat Red Hat OpenShift AI 3.4 Veröffentlicht: (vor 6 Monaten)

Bekannt ausgenutzt — BerriAI LiteLLM Command Injection Vulnerability

CISA hat am 08.06.2026 bestätigt, dass diese Schwachstelle in echten Angriffen genutzt wird. Frist für US-Bundesbehörden: 22.06.2026.

Erforderliche Maßnahme: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable. This vulnerability affects a common open-source component, third-party library, or a protocol used by different products. Please check with specific vendors for information on patching status. For more information, please see: https://github.com/BerriAI/litellm/security/advisories/GHSA-v4p8-mg3p-g94g ; https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable ; https://nvd.nist.gov/vuln/detail/CVE-2026-42271

Beschreibung

LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.74.2 to before version 1.83.7, two endpoints used to preview an MCP server before saving it — POST /mcp-rest/test/connection and POST /mcp-rest/test/tools/list — accepted a full server configuration in the request body, including the command, args, and env fields used by the stdio transport. When called with a stdio configuration, the endpoints attempted to connect, which spawned the supplied command as a subprocess on the proxy host with the privileges of the proxy process. The endpoints were gated only by a valid proxy API key, with no role check. Any authenticated user — including holders of low-privilege internal-user keys — could therefore run arbitrary commands on the host. This issue has been patched in version 1.83.7.

Schwachstellentyp (CWE): CWE-77CWE-78

Daten: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Wiedergegeben wie in der Quelle, auf Englisch.

Betroffene Produkte und Versionen

HerstellerProduktVersionen
BerriAI litellm >= 1.74.2, < 1.83.7
litellm litellm 1.74.2 – < 1.83.7
openshift ai 2.25 —
openshift ai 3.3 —
openshift ai 3.4 —
Red Hat Exploit Intelligence —
redhat openshift ai 2.25 – < 2.25.8
Red Hat Red Hat Ansible Automation Platform 2 —
Red Hat Red Hat OpenShift AI 2.25 all versions
Red Hat Red Hat OpenShift AI 3.3 all versions
Red Hat Red Hat OpenShift AI 3.4 all versions
Red Hat Red Hat OpenShift AI (RHOAI) —

Referenzen und Patches

CPE-Treffer (NVD) (4)

  • cpe:2.3:a:litellm:litellm:*:*:*:*:*:*:*:* ≥ 1.74.2 < 1.83.7
  • cpe:2.3:a:redhat:openshift_ai:*:*:*:*:*:*:*:* ≥ 2.25 < 2.25.8
  • cpe:2.3:a:redhat:openshift_ai:*:*:*:*:*:*:*:* ≥ 3.3 < 3.3.4
  • cpe:2.3:a:redhat:openshift_ai:3.4:*:*:*:*:*:*:*