6.8Mittel

CVE-2026-33997Moby: Off-by-one error in plugin privilege validation

moby moby; Red Hat Multicluster Global Hub 1.4.5; Red Hat Multicluster Global Hub 1.6.5; Red Hat Red Hat multicluster global hub 1.5.3 Veröffentlicht: (vor 7 Monaten)

Beschreibung

Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows plugins privilege validation to be bypassed during docker plugin install. Due to an error in the daemon's privilege comparison logic, the daemon may incorrectly accept a privilege set that differs from the one approved by the user. Plugins that request exactly one privilege are also affected, because no comparison is performed at all. This issue has been patched in version 29.3.1.

Schwachstellentyp (CWE): CWE-193CWE-266

Daten: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Wiedergegeben wie in der Quelle, auf Englisch.

Betroffene Produkte und Versionen

Referenzen und Patches

CPE-Treffer (NVD) (1)

  • cpe:2.3:a:docker:engine:*:*:*:*:*:*:*:* < 29.3.1