7.8Hoch
CVE-2026-27271Illustrator | Heap-based Buffer Overflow (CWE-122)
Beschreibung
Illustrator versions 29.8.4, 30.1 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Schwachstellentyp (CWE):
CWE-122
Daten: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Wiedergegeben wie in der Quelle, auf Englisch.
Betroffene Produkte und Versionen
| Hersteller | Produkt | Versionen | |
|---|---|---|---|
| adobe | illustrator | 29.0 – < 29.8.5 | |
| Adobe | Illustrator Desktop 2025 | ≤ 29.8.4, fixed 29.8.5 | |
| Adobe | Illustrator Desktop 2026 | ≤ 30.1, fixed 30.2 |
Referenzen und Patches
- https://helpx.adobe.com/security/products/illustrator/apsb26-18.html vendor-advisoryVendor Advisory
CPE-Treffer (NVD) (2)
cpe:2.3:a:adobe:illustrator:*:*:*:*:*:*:*:*≥ 29.0 < 29.8.5cpe:2.3:a:adobe:illustrator:*:*:*:*:*:*:*:*≥ 30.0 < 30.2