9.1Kritisch

CVE-2025-68670xrdp improperly checks bounds of domain string length, which leads to Stack-based Buffer Overflow

neutrinolabs xrdp Veröffentlicht: (vor 9 Monaten)

Beschreibung

xrdp is an open source RDP server. xrdp before v0.10.5 contains an unauthenticated stack-based buffer overflow vulnerability. The issue stems from improper bounds checking when processing user domain information during the connection sequence. If exploited, the vulnerability could allow remote attackers to execute arbitrary code on the target system. The vulnerability allows an attacker to overwrite the stack buffer and the return address, which could theoretically be used to redirect the execution flow. The impact of this vulnerability is lessened if a compiler flag has been used to build the xrdp executable with stack canary protection. If this is the case, a second vulnerability would need to be used to leak the stack canary value. Upgrade to version 0.10.5 to receive a patch. Additionally, do not rely on stack canary protection on production systems.

Schwachstellentyp (CWE): CWE-121CWE-787

Daten: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Wiedergegeben wie in der Quelle, auf Englisch.

Betroffene Produkte und Versionen

HerstellerProduktVersionen
debian debian linux 11.0
neutrinolabs xrdp < 0.10.5

Referenzen und Patches

CPE-Treffer (NVD) (2)

  • cpe:2.3:a:neutrinolabs:xrdp:*:*:*:*:*:*:*:* < 0.10.5
  • cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*