8.8Hoch

CVE-2025-26467Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (4.0.16 only)

Apache Software Foundation Apache Cassandra Veröffentlicht: (vor 1 Jahr)

Beschreibung

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra 3.0.30, 3.11.17, 4.0.16, 4.1.7, 5.0.2, but this advisory is only for 4.0.16 because the fix to CVE-2025-23015 was incorrectly applied to 4.0.16, so that version is still affected. Users in the 4.0 series are recommended to upgrade to version 4.0.17 which fixes the issue. Users from 3.0, 3.11, 4.1 and 5.0 series should follow recommendation from CVE-2025-23015.

Schwachstellentyp (CWE): CWE-267

Daten: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Wiedergegeben wie in der Quelle, auf Englisch.

Betroffene Produkte und Versionen

HerstellerProduktVersionen
Apache Software Foundation Apache Cassandra 4.0.16
apache cassandra 3.0.0 – < 3.0.31

Referenzen und Patches

CPE-Treffer (NVD) (5)

  • cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:* ≥ 3.0.0 < 3.0.31
  • cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:* ≥ 3.11.0 < 3.11.18
  • cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:* ≥ 4.0.0 < 4.0.17
  • cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:* ≥ 4.1.0 < 4.1.8
  • cpe:2.3:a:apache:cassandra:*:*:*:*:*:*:*:* ≥ 5.0.0 < 5.0.3