CVE-2024-48944Apache Kylin: SSRF vulnerability in the diagnosis api
Beschreibung
Server-Side Request Forgery (SSRF) vulnerability in Apache Kylin. Through a kylin server, an attacker may forge a request to invoke "/kylin/api/xxx/diag" api on another internal host and possibly get leaked information. There are two preconditions: 1) The attacker has got admin access to a kylin server; 2) Another internal host has the "/kylin/api/xxx/diag" api endpoint open for service. This issue affects Apache Kylin: from 5.0.0 through 5.0.1. Users are recommended to upgrade to version 5.0.2, which fixes the issue.
Daten: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Wiedergegeben wie in der Quelle, auf Englisch.
Betroffene Produkte und Versionen
| Hersteller | Produkt | Versionen | |
|---|---|---|---|
| Apache Software Foundation | Apache Kylin | 5.0.0 – ≤ 5.0.1 | |
| apache | kylin | 5.0.0 – < 5.0.2 |
Referenzen und Patches
- https://lists.apache.org/thread/1xxxtdfh9hzqsqgb1pd9grb8hvqdyc9x vendor-advisoryMailing ListVendor Advisory
- http://www.openwall.com/lists/oss-security/2025/03/27/5 Mailing ListThird Party Advisory
CPE-Treffer (NVD) (1)
cpe:2.3:a:apache:kylin:*:*:*:*:*:*:*:*≥ 5.0.0 < 5.0.2