10.0Kritisch KEV

CVE-2022-24816Improper Control of Generation of Code in jai-ext

geosolutions-it jai-ext; geosolutionsgroup jai-ext Veröffentlicht: (vor 4 Jahren)

Bekannt ausgenutzt — OSGeo GeoServer JAI-EXT Code Injection Vulnerability

CISA hat am 26.06.2024 bestätigt, dass diese Schwachstelle in echten Angriffen genutzt wird. Frist für US-Bundesbehörden: 17.07.2024.

Erforderliche Maßnahme: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable. This vulnerability affects a common open-source component, third-party library, or a protocol used by different products. The patched JAI-EXT is version 1.1.22: https://github.com/geosolutions-it/jai-ext/releases/tag/1.1.22, https://github.com/geosolutions-it/jai-ext/security/advisories/GHSA-v92f-jx6p-73rx; https://nvd.nist.gov/vuln/detail/CVE-2022-24816

Beschreibung

JAI-EXT is an open-source project which aims to extend the Java Advanced Imaging (JAI) API. Programs allowing Jiffle script to be provided via network request can lead to a Remote Code Execution as the Jiffle script is compiled into Java code via Janino, and executed. In particular, this affects the downstream GeoServer project. Version 1.2.22 will contain a patch that disables the ability to inject malicious code into the resulting script. Users unable to upgrade may negate the ability to compile Jiffle scripts from the final application, by removing janino-x.y.z.jar from the classpath.

Schwachstellentyp (CWE): CWE-94

Daten: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Wiedergegeben wie in der Quelle, auf Englisch.

Betroffene Produkte und Versionen

HerstellerProduktVersionen
geosolutions-it jai-ext < 1.1.22
geosolutionsgroup jai-ext < 1.1.22

Referenzen und Patches

CPE-Treffer (NVD) (1)

  • cpe:2.3:a:geosolutionsgroup:jai-ext:*:*:*:*:*:*:*:* < 1.1.22