8.1Hoch KEV

CVE-2018-15133Laravel Deserialization of Untrusted Data Vulnerability

laravel laravel Veröffentlicht: (vor 8 Jahren)

Bekannt ausgenutzt — Laravel Deserialization of Untrusted Data Vulnerability

CISA hat am 16.01.2024 bestätigt, dass diese Schwachstelle in echten Angriffen genutzt wird. Frist für US-Bundesbehörden: 06.02.2024.

Erforderliche Maßnahme: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable. https://laravel.com/docs/5.6/upgrade#upgrade-5.6.30; https://nvd.nist.gov/vuln/detail/CVE-2018-15133

Beschreibung

In Laravel Framework through 5.5.40 and 5.6.x through 5.6.29, remote code execution might occur as a result of an unserialize call on a potentially untrusted X-XSRF-TOKEN value. This involves the decrypt method in Illuminate/Encryption/Encrypter.php and PendingBroadcast in gadgetchains/Laravel/RCE/3/chain.php in phpggc. The attacker must know the application key, which normally would never occur, but could happen if the attacker previously had privileged access or successfully accomplished a previous attack.

Schwachstellentyp (CWE): CWE-502

Daten: CVE.org, NVD, CISA KEV, FIRST EPSS, Ubuntu. Wiedergegeben wie in der Quelle, auf Englisch.

Betroffene Produkte und Versionen

HerstellerProduktVersionen
laravel laravel ≤ 5.5.40

Referenzen und Patches

CPE-Treffer (NVD) (2)

  • cpe:2.3:a:laravel:laravel:*:*:*:*:*:*:*:* ≤ 5.5.40
  • cpe:2.3:a:laravel:laravel:*:*:*:*:*:*:*:* ≥ 5.6.0 ≤ 5.6.29